NET/סביבת העבודה

מתוך ויקיספר, אוסף הספרים והמדריכים החופשי
< NET
קפיצה לניווט קפיצה לחיפוש
תכנות בסביבת NET








פרק זה יסביר לכם כיצד להשתמש בסביבת העבודה של Visual Studio .NET. במהלך פרק זה נעשה שימוש בתמונה הבאה:

תמונה 1 - פירוט מראה התוכנה Visual Studio .NET

יצירת פרויקט חדש[עריכה]

ע"מ ליצור פרויקט חדש יש ללחוץ על תפריט: File - NewProject או על הכפתור המתאים בסרגל כלים לוח מקשים.jpgCtrl+N.

החלון הבא ייפתח:
תמונה 2 - חלון פרויקט חדש

יש לבחור בשפה הרצויה ובסוג הפרויקט. בד"כ נבחר Windows Application - ישום לחלונות.
אם רוצים שהפרויקט יהיה אינטרנטי (ASP.NET) - יש לבחור בתפריט: File - New Web Site.
לאחר שיצרנו פרויקט, נוצר לנו טופס אחד בשם Form1.

הסבר כללי על סביבת העבודה[עריכה]

כפי שאתם רואים בתמונה 1. חלון ה Visual Studio .NET מורכב מהרבה חלוניות זה לצד זה.
ראשית נציג את התפריטים (A).

התפריטים[עריכה]


תפריט File - מכיל פקודות עבור פרויקטים וקבצים: יצירה, פתיחה, הוספה, שמירה, הדפסה וסגירה.
תפריט Edit - מכיל פקודות עריכה: גזירה, העתקה, הדבקה, ביטול, חיפוש והחלפה.
תפריט View - מכיל פקודות תצוגה: סוג תצוגה, הצגה של חלוניות נוספות וסרגלי כלים.
תפריט Project - מכיל פקודות עבור הפרויקט הנוכחי: הוספת פריטים ו-Refrerance.
תפריט Build - מכיל פקודות יצירה של קובץ בר-הרצה.
תפריט Debug - מכיל פקודות לטיפול בשגיאות וביצוע הרצה צעד אחר צעד.
תפריט Data - מכיל פקודות עבור קישורים למסדי נתונים.
תפריט Format - מכיל פקודות עבור עיצוב הפקד על גבי הטופס.
תפריט Tools - מכיל כלים רבים. כגון: הוספת רכיבים (Add-Ins), התאמה אישית של סרגלי הכלים, אפשרויות מתקדמות ועוד.
תפריט Window - מאפשר ניהול החלונות בסביבת העבודה.
תפריט Community - מכיל קישורים לפרומים וקהילות מפתחים.
תפריט Help - מאפשר קבלת עזרה מMSDN והאינטרנט.

סרגלי הכלים[עריכה]

סרגלי הכלים (B) מאפשרים גישה מהירה לפקודות נוספות. ניתן להוסיף סרגלי כלים ע"י לחיצה על לחצן העכבר הימני על סרגל כלים. וגם לערוך ולהוסיף סרגלי כלים ע"י לחיצה על התאמה אישית בתפריט.
מלבד התפריטים וסרגלי הכלים יש עוד מגוון רחב של חלונות.


חלונות[עריכה]

כפי שניתן לראות בתמונה 1, במרכז היישום נמצאים החלונות העיקריים - הטופס (D) והקוד (E). חלון המסומן בכוכבית מציין קובץ שלא נשמר. ניתן לעבור בין חלון לחלון ע"י הכרטיסיות המופיעות למעלה (C) לוח מקשים.jpgCtrl+Tab / Ctrl+F6.

. מסביב לחלונות אלו ימצאו חלונות העזר:
Server Explorer - מכיל קישורים למסדי נתונים ולאובייקט השרת (אם הגדרת את המחשב כשרת). אפשר להוסיף קישור למסד נתונים היושב על המחשב ע"י לחיצה על הכפתור Connect To DataBase הנמצא בחלונית זו (H).
Tool Box - מכיל את הפקדים. ע"מ להוסיף פקד לטופס יש לגרור את הפקד הרצוי לתוך הטופס. לחיצה על Ctrl בעת הגרירה משכפלת את הפקד. (I)
Solution Explorer - מכיל את כל הקבצים בפרויקט הנוכחי. וכן גישה למאפייני הפרויקט ול Reference (J).
Properties - נותן גישה של כל המאפיינים של האובייקט שנבחר (K).
כפי שניתן לראות בתמונה 1, ישנם חלונות שלא מוסתרים שיוצגו בלחיצה עליהם (L) וחלונות שלא מוצגים בכלל והגישה אליהם באמצעות תפריט View נציג כמה מהם:
Object Browser - חלון המציג את כל המחלקות הזמינים וחבריה.
Data Sources - מאפשר גישה ישירה לנתונים במסד נתונים.
Error List - מציג שגיאות הידור.
Immediate Window - נותן אפשרות לביצוע בדיקות על נתונים ופונקציות במהלך הריצה בלי לפגוע במהלך התכנית. להסבר נוסף עיין בפרק בדיקת שגיאות.
Watch - מציג את ערכי המשנים בזמן ריצה. להסבר נוסף עיין בפרק בדיקת שגיאות.

לחיצה על התפריט בפינה הימנית למעלה של חלונית (M) תפתח תפריט עם אפשרות התנהגות של החלונית. לחיצה על הנעץ תאפשר הסתרה אוטומטית.

הוספת פריטים[עריכה]

ע"מ להוסיף טופס או מחלקה (Class) לפרויקט יש לבחור בתפריט Project ובאובייקט הרצוי.

הטופס[עריכה]

חלון הטופס (D) מראה את התצוגה המקדימה של מראה הטופס בזמן ההידור. כפי שכבר אמרנו, ע"מ להוסיף פקד, יש לגרור אותו מה-ToolBox.

תמונה 3 - חלון הטופס

אחרי שהוספנו את הפקד ניתן לגרור אותו למיקום אחר על גבי הטופס. כפי שרואים בתמונה 3 - כשמזיזים פקד על הטופס בזמן שיש לידו פקד אחר - מוצגים קווי יושר המאפשרים ליישר את הפקד הנוכחי לפקד שלידו. ע"מ לבטל אפשרות זו יש ללחוץ על Alt בזמן הגרירה. לחיצה על Ctrl תיצור עותק של הפקד.
ע"מ לשנות את גודל הפקד יש לגרור את אחד מתשעת הריבועים לכייון הרצוי (לא זמין בכל הפקדים).
אפשרוית רבות נוספות נמצאות בסרגל הכלים 'Layout.

חלון הקוד[עריכה]

חלון הקוד (E) מאפשר גישה נוחה מאוד לכתיבת הקוד. הקוד מוצג בצבעים שונים עבור סוג האובייקט. כפי שניתן לראות, חלון הקוד מכווץ בלוקי קוד ע"י הריבועים [-] ו [+]לוח מקשים.jpgCtrl+M+M.



ניתן להוסיף אירוע ע"י בחירת מחלקה מהתיבה המשולבת השמאלית (F) ובאירוע הרצוי מהתיבה המשולבת הימנית (G). או לבחור בשגרה של המחלקה אם בוחרים בתיבה משולבת הימנית בשם המחלקה.
לחיצה על Ctrl+Space בחלון הקוד תציג רשימה של כל האובייקטים הזמינים להוספה.
ניתן להוסיף קטע קוד מוכן ע"י הפקודה Insert Snippet. לוח מקשים.jpgCtrl+k+x.



ניתן לסמן את הטקסט הנבחר כהערה ע"י התו ' (גרש) או ע"י לחיצה על Comment Selection לוח מקשים.jpgCtrl+K+C.

.
ניתן לסמן את השורה בסימניה ע"י הפקודה Toogle Bookmark. לוח מקשים.jpgCtrl+K+K.


MSDN[עריכה]

ע"מ לקבל עזרה, יש לשים את הסמן על הפקודה הרצויה או לבחור את הפקד הרצוי וללחוץ על F1 או לבחור בתפריט Help.

Wikibooks-logo.svg  חלק זה של הספר הינו קצרמר. אתם מוזמנים לתרום לוויקיספר ולערוך אותו.