GIMP/צבעים

מתוך ויקיספר, אוסף הספרים והמדריכים החופשי
קפיצה אל: ניווט, חיפוש
עריכת תמונה GIMP
צבעים
שמירה

גימפ מבין מספר מודלים לייצוג צבע בדרגת תמיכה ואיכות משתנות. קיימת תמיכה במצבי הצבעוניות הבאים: RGB, grayscale ו- indexed . לשינוי מצב צביעה יש לגשת לתפריט בראש חלון התמונה ולבחור: Image > Mode


מצבי צבעוניות[עריכה]

מצבי הצבע הנתמכים:


  • "צבע אמיתי" (True Colour (RGB: למצב זה התמיכה הטובה ביותר בגימפ. הוא מורכב מ 3 ערוצי צבע בעלי 256 וריאציות גוון בכל אחד מהם, שמסתכמים לכדי 16.7 מיליון צבעים - 256 * 256 * 256.

    פורמטים של מצב צביעה זה שגימפ תומך בהם: XCF, PNG, TGA, TIFF, SGI, BMP.

  • סולם אפור Grayscale: גימפ תומך היטב בפורמט זה, שמשתמש בערוץ אחד בלבד להצגת תמונה בשחור-לבן. רוב הכלים של גימפ עובדים היטב ומספקים את התוצאה הצפויה, להוציא כלים שדורשים קיום של נתוני צבע

    פורמטים נתמכים: XCF, PNG, TGA, TIFF, SGI.

  • פלטה מותאמת Indexed: במצב צביעה זה התמונה מורכבת מפלטת צבעים מותאמת המכילה 256 צבעים. מטרת מצב זה היא לרוב הקטנת גודל קובץ התמונה, או במקרים מסוימים חיסכון בכוח מחשוב בעריכתה. כאשר מעבירים תמונה למצב צביעה זה, או כאשר מפחיתים "עומק צבע" ("color depth") של תמונה, האופציה "עידון השתנות צבע" מאפשרת לקבוע כיצד הצבעים יפוזרו. לתוצאות האיכותיות ביותר עבור תמונות עם שינויי גוון הדרגתיים מומלץ לבחור "Floyd-Steinberg dithering". אופציה זו תוסיף גרעיניות לתמונה, אבל תפחית אפקט של ריצוע צבע. מצד שני עידון השתנות צבע (dithering) יגדיל במקצת את גודל הקובץ לכן אם זו המטרה מומלץ להשתמש באפשרות זו בערכים נמוכים או לא להשתמש בה בכלל בעת שמירה בפורמטים GIF, PNG או BPM עם האפשרות "Run-Length Encoded" מופעלת.

    פורמטים נתמכים: XCF, PNG, GIF, BMP.

  • מונוכרום Monochrome: שני צבעים, לעתים קרובות שחור-לבן, גימפ רואה אפשרות צביעה זו כתמונה עם פלטה מותאמת בעלת 2 צבעים בלבד.

    פורמטים נתמכים: XCF, PNG, GIF, BMP.

בתפריט הצבע בראש החלון קיימות הכניסות הבאות:

  • Image > Mode > RGB
  • Image > Mode > Grayscale
  • Image > Mode > Indexed

ערוץ אלפא[עריכה]

ללא קשר למצב הצביעה, הוספת ערוץ אלפא מאפשר לתמונה אזורים בעלי שקיפות בדרגה משתנה. כל פיקסל בתמונה מקבל ערך שקיפות בין 0 ל 255. שימוש בתמונה בעלת ערוץ אלפא מאפשר ליצור תמונות עם חורים או אזורי שקיפות חלקית עבור שימושי WEB, או גרפיקה תלת ממדית.

פורמטים שתומכים בערוץ אלפא באופן מלא: XCF, PNG, TIFF, TGA, SGI. פורמטים שתומכים בערוץ אלפא רק עבור ערכים של שקיפות מלאה וצבע אטום (כלומר חסר שקיפות): GIF, XPM.

הערה לגבי דפדפנים: אחת התכונות הידועות של דפדפנים היא שקיימת תמיכה בשקיפות תמונות בדפדפנים נפוצים רק החל מאינטרנט אקספלורר 7.

בתפריט ערוץ אלפא בראש החלון קיימות הכניסות הבאות:

  • Layer > Transparency > Add Alpha Channel
  • Layer > Transparency > Remove Alpha Channel
  • Layer > Transparency > Add to Selection

פילטרים/כלי צבע[עריכה]

בתפריט הראשי שבחלון התמונה תחת Image אפשר למצוא מספר פונקציות עיבוד תמונה נוספות:

  1. Image > Mode > Decompose יפרק את התמונה לסדרה של תמונות בסולם אפור, בהתאמה לאחד מכמה מודלים של צביעה.
  2. Image > Mode > Compose מבצע את הפעולה ההפוכה ומרכיב סדרה כזו לתמונה צבעונית. ניתן להגיע לאפקטים מדהימים בשיטה זו, ע"י הרכבה מחדש של הסדרה ע"פ מודל שונה מזה ששימש לפירוק התמונה המקורית.
  3. Image > Colours מספק מספר אפשרויות להתאמות צבע.
  4. Image > Filters > Colours גם כאן קיימים כמה אפקטים של צביעה.

מקורות[עריכה]

עריכת תמונה GIMP
צבעים
שמירה