Java/שלום עולם!

מתוך ויקיספר, אוסף הספרים והמדריכים החופשי
קפיצה לניווט קפיצה לחיפוש
התקנת סביבת פיתוח Java
שלום עולם!
יסודות השפה
ניווט בנושא הכנה

נתחיל עם כתיבה והרצה של תוכנית פשוטה הכותבת על המסך "Hello World".

יצירת קובץ המחלקה[עריכה]

עלינו ליצור ראשית קובץ גא'ווה שבוא נכתוב את קוד המקור, את הקובץ ניתן אחר כך לקמפל ולהריץ.

עורך טקסט[עריכה]

אם הינך עובד עם עורך טקסט פשוט, ראה בפרק זה כיצד לכתוב, לקמפל ולהריץ קוד על ידי שימוש בשורת הפקודות.

Eclipse[עריכה]

אם הינך עובד בסביבת פיתוח Eclipse עקוב אחר ההוראות הבאות

  1. לאחר העלאת התוכנה, בחרו בחרו מתוך התפריט File או משורת המשימות את אפשרות "New" ובחרו באפשרות "Java Project".
  2. בחלון הדו שיח שנפתח התעלם מעומס האפשרויות, התרכז רק במתן שם כלשהו לפרויקט (למען הנוחות, נניח כי השם הוא "MyProject").
  3. לאחר כתיבת שם הפרויקט לחצו על כפתור ה-"Finish", שנמצא בתחתית החלון.

עד כאן יצרנו פרויקט חדש, שיכיל את כל הקבצים איתם נעבוד. כעת יש ליצור מחלקה (Class) חדשה.

  1. בחרו שנית באפשרות "New", ובחרו הפעם ב- "Class".
  2. כעת יפתח חלון ליצירת מחלקה חדשה. גם כאן נתעלם מהאפשרויות המוצעות לנו, ורק נתרכז בלתת למחלקה שם.
    • שם המחלקה יכול להכיל רק אותיות מספרים וקו תחתון, בנוסף לא ניתן להתחיל במספר.
  3. ניתן למחלקה את השם "HelloWorld" כי שם זה משקף היטב את תפקידה של התכנית.
  4. סמן את האפשרות "public static void main(String[] args)" שנמצאת באזור התחתון של החלון, זה יגרום לקובץ להווצר מראש עם מרבית מהקוד שאנו זקוקים לו.
  5. לחצו על כפתור ה-"Finish" על מנת ליצור את המחלקה.

כעת תוכלו לראות את תוכן הקובץ בעורך של eclipse.

NetBeans[עריכה]

אם הינך עובד בסביבת פיתוח NetBeans עקוב אחר ההוראות הבאות

  1. לאחר העלאת התוכנה, בחר מתוך התפריט File את אפשרות "New Project...".
  2. בתיבה השמאלית בחר ב- "Java" ובתיבה הימנית בחר ב- "Java application".
  3. לחץ על Next. תן שם לפרויקט ובטל את הסימון של שתי התיבות בתחתית החלון.
  4. בחר מתוך התפריט File את האפשרות "New File...".
    • בתיבה העליונה בחר בפרויקט שיצרתה.
    • בתיבה השמאלית בחר ב- "Java".
    • בתיבה הימנית בחר ב- "Java class".
  5. לחץ על "Next". תן שם למחלקה (במקרה הזה "HelloWorld"), וודא שבתיבה "Project" נמצא הפרויקט שלך ולחץ Finish.

BlueJ[עריכה]

אם הינך עובד בסביבת פיתוח BlueJ עקוב אחר ההוראות הבאות

  1. לאחר העלאת התוכנה, בחר מתוך התפריט Project את אפשרות "New Project...".
  2. תן שם לפרוייקט ולחץ על אישור.
  3. עכשיו, לחץ על הלחצן "New Class", שנמצא בצד הימיני של החלון.
  4. תן שם למחלקה (במקרה הזה "HelloWorld").
  5. שימו לב שמתוך האפשרויות למטה מסומנת האפשרות "Class". אם מסומנת אפשרות אחרת, שנו זאת.
  6. אחרי יצירת המחלקה, היא תופיע על משטח העבודה הגדול שבאמצע החלון, כאשר היא נראית כמו מלבן שעליו רשום "HelloWorld" (או שיופיע השם שבוא בחרתם עם בחרתם בשם אחר).
  7. לחיצה כפולה עליו תפתח חלון עריכה.

כתיבת התוכנית[עריכה]

העתק את השורות הבאות אל תוך תוכן הקובץ ושמור אותו

public class HelloWorld {
	public static void main(String[] args) {
		System.out.println("Hello World!");
	}
}


שימו לב כי אם אתם עובדים בתוכנה ייעודית לג'אווה, ייתכן מאוד וחלק משורות הקוד יתווספו באופן אוטומטי על ידי התוכנה.
בשלב זה, ייתכן ויהיה נוח יותר למחוק אותן ולהעתיק שורות אלה.

הסבר[עריכה]

public class HelloWorld {

}

השורה הראשונה כוללת את ההכרזה על המחלקה. המילה class, מכריזה שזוהי מחלקה.
המילה public מכריזה כי זוהי מחלקה ציבורית, כלומר - ניתן לגשת אל מחלקה זו מכל מחלקה אחרת.

לאחר מכן מצוין שם המחלקה, חשוב: שם המחלקה חייב להיות זהה לשם הקובץ.
לדוגמה שם הקובץ הוא HelloWorld.java אז שמה של המחלקה יהיה HelloWorld (יש להקפיד על אותיות גדולות / קטנות)

.
אם שם המחלקה ושם הקובץ לא יהיו זהים, התכנית לא תרוץ.

לאחר שם המחלקה מופיע סוגריים מסולסלות פותח, שימו לב שבשורה האחרונה נמצא גם אחד סוגר.
בג'אווה סוגריים מסולסלים מיצגים בלוקים של קוד, ובאמצעות הזחות (Indentation)

ניתן לראות בברור איזה בלוק קוד שייך למה.

משמעות סוגריים אילו היא לסמן את תחילה וסופה של המחלקה HelloWorld.


public static void main(String[] args) {

}

אם הינכם זוכרים בפרק הכנה דיברנו על המונח של שיטות או מתודות ויותר ספציפי על השיטה הראשית, הקוד הנ"ל מצהיר על השיטה הראשית.
נדבר בשלב מאוחר יותר על שיטות יותר לעומק ומילות מפתח כמו public,‏ static, ו- void יוסברו יותר לעומק. כמו גם גם מערכים ומחרוזות.
וכמו עם המחלקה, את התחלתה וסופה של השיטה הראשית אנו מסמנים עם סוגריים מסולסלים.


System.out.println("Hello World!");

זאת הפקודה שמדפיסה מחרוזת אל הקונסולה (console)

בשורה חדשה. המחרוזת שמודפסת היא "Hello World!".

הרצת התוכנית[עריכה]

עורך טקסט[עריכה]

אם הינך עובד עם עורך טקסט פשוט, ראה בפרק זה כיצד לכתוב, לקמפל ולהריץ קוד על ידי שימוש בשורת הפקודות.

Eclipse[עריכה]

אם הינך עובד בסביבת פיתוח Eclipse, לחץ עכבר ימני בתוך הלשונית בה אתם עובדים. מהתפריט שייפתח בחרו "Run As"‏ › "Java Application".
ניתן לעשות את אותה פעולה על ידי בחירה בתפריט "Run"‏ › "Run As"‏ › "Java Application".
או לחיצה על האיקון הירוק עם החץ הלבן בשורת המשימות.
הפלט אמור להופיע בחלון קטן (Console)

בחלקו התחתון של המסך.

במידה וחלון כזה לא מופיע, הכנסו לתפריט "Window" ‏ › "Show View" ‏ › "Console" והחלון אמור להופיע.

BlueJ[עריכה]

סגרו את חלון העריכה של התוכנית. במידה ותישאלו אם רצונכם לשמור - שמרו את הקובץ. כעת, במשטח העבודה לחצו עם הלחצן הימני של העכבר על המחלקה ובחרו "Compile". לאחר מכן לחצו שוב על הלחצן הימני והפעם בחרו ב"void main(String[] args)". בחלון שיפתח בחרו "OK", ואז יוצג בפניכם חלון ובו תוצאות התוכנית - אם הכל ילך כשורה, תראו על חלון זה את הטקסט "Hello World".

בעיות נפוצות[עריכה]

  • התוכנה כלל לא עולה - ייתכן ולא התקנתם כראוי חבילת Java כפי שהוסבר בפרק הקודם. ייתכן גם שהתוכנה עצמה לא מותקנת כראוי ויש להתקינה מחדש. שימו לב גם ש-eclipse היא תוכנה הדורשת משאבים רבים, ועל מחשבים חלשים היא עשוייה לפעול בצורה איטית מאוד.
  • התוכנית שכתבנו לא פועלת - יכולות להיות לכך סיבות רבות. שימו לב היטב ששום טעות לא נעשתה בכתיבת הטקסט, אפילו לא עם בלבול בין אות גדולה לקטנה או סוגריים שנשכחו. רצוי להעתיק את הטקסט באמצעות "העתק-הדבק". וודאו גם כי שם הקובץ תואם בדיוק לשם המחלקה.


התקנת סביבת פיתוח Java
שלום עולם!
יסודות השפה